$re = '/[^\-+\*=]+\s*[\-+\*=]{1,2}\s*(\'[^\']+\')\s*\&\&/';
$str = 'mydate == \'one day ago\' && mydate > \'2014-05-16 16:00:00\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);