re = /[^\-+\*=]+\s*[\-+\*=]{1,2}\s*('[^']+')\s*\&\&/
str = 'mydate == \'one day ago\' && mydate > \'2014-05-16 16:00:00\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end