import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bid\\b=\\[(.+?)\\]";
final String string = "@client.test.annotations.TestInfo(id=[]) //ignore this time\n"
+ " @org.testng.annotations.Test(alwaysRun=true,...\n"
+ "@client.test.annotations.TestInfo(id=[C10137, C12121])\n"
+ " @org.testng.annotations.Test(alwaysRun=true,...\n"
+ "@client.test.annotations.TestInfo(id=[C10137])\n"
+ "@org.testng.annotations.Test(alwaysRun=false, expectedExceptions=[]..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}