# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)UPDATE[ \t\n]{1,}(fact)(.*)\n(from)?([ \t\n]{1,})?(.*)?\n*set[ \n\t]{1,}(coloana)[ \t\n]*=[ \t\n]*(ifnull\(\s*)*([\w\d]*)([\ ,'\w\n\t)(\n=.]*);"
test_str = ("update fact,x2,asdasjsdjbmfeweoewo\n"
"from asdas,asaskdvd\n"
"set coloana = ifnull( ifnull( col2,'Test'), 'Test2')\n"
"where c = c.s.\n"
"and asdsa = asda.asda;\n\n"
"UPdate fact,x2\n"
"set coloana = ifnull(col2,'Test')\n"
"where c = c.s.;\n\n"
"update\n"
" fact,x2\n"
"from\n"
" asdas\n"
"set coloana = ifnull(col2,'Test')\n"
"where c = c.s.\n"
"and asdsa = asda.asda;\n\n"
"update fact,x2\n"
"from asdas\n"
"set coloana = (select x from y where x.fg = x2.asfds)\n"
"where c = c.s.\n"
"and asdsa = asda.asda;")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.