import Foundation
let pattern = #"(?i)UPDATE[ \t\n]{1,}(fact)(.*)\n(from)?([ \t\n]{1,})?(.*)?\n*set[ \n\t]{1,}(coloana)[ \t\n]*=[ \t\n]*(ifnull\(\s*)*([\w\d]*)([\ ,'\w\n\t)(\n=.]*);"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
update fact,x2,asdasjsdjbmfeweoewo
from asdas,asaskdvd
set coloana = ifnull( ifnull( col2,'Test'), 'Test2')
where c = c.s.
and asdsa = asda.asda;
UPdate fact,x2
set coloana = ifnull(col2,'Test')
where c = c.s.;
update
fact,x2
from
asdas
set coloana = ifnull(col2,'Test')
where c = c.s.
and asdsa = asda.asda;
update fact,x2
from asdas
set coloana = (select x from y where x.fg = x2.asfds)
where c = c.s.
and asdsa = asda.asda;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}