import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d+\\.)(\\w[\\w\\-]{0,24}\\w)\\.";
final String string = "estadão.com.br\n"
+ "domínio.com.br\n"
+ "90.com\n"
+ "-errado.com\n"
+ "aindaerrado-.com\n"
+ "OK.com\n"
+ "1.com.br\n"
+ "1a.org\n"
+ "łðµsdaf.com\n"
+ "estadao.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}