re = /^(?!\d+\.)([\p{L}0-9][\p{L}0-9\-]{0,24}[\p{L}0-9])\./m
str = 'estadão.com.br
domínio.com.br
90.com
-errado.com
aindaerrado-.com
OK.com
1.com.br
1a.org
łðµsdaf.com
estadao.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end