using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(export[^(]*)(\(([^)]+)\))([^{]*)(\{([^}]+)\})";
string input = @"export default function something($123, something, wauw) {
function(random) {
return random;
}
}
export default function(something, wauw) {
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}