import Foundation
let pattern = #"(?P<destination>\d+\.\d+\.\d+\.\d+)\ +(?P<gateway>\d+\.\d+\.\d+\.\d+)\ +(?P<mask>\d+\.\d+\.\d+\.\d+)\ +\w+\ +\d+\ +\d+\ +\d+\ +(?P<interface>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
0.0.0.0 192.168.100.254 0.0.0.0 UG 100 0 0 enp2s0
10.8.0.1 10.8.0.109 255.255.255.255 UGH 0 0 0 tun0
10.8.0.109 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
192.168.10.0 10.8.0.109 255.255.255.0 UG 0 0 0 tun0
192.168.100.0 0.0.0.0 255.255.255.0 U 100 0 0 enp2s0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)