Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=where)(.*?)((ORDER BY|GROUP BY|HAVING|LIMIT|OFFSET|$).*)
/
gsi
Input 1
1
New
select "DIM_1"."col1", "DIM_2"."col2" , "DIM_3"."col3" , "DIM_4"."col4" , "FAT_1"."col5" from "FAT_1", "DIM_1", "DIM_2", "DIM_3", "DIM_4" where "DIM_1"."col1" IS NOT NULL AND "DIM_2"."col2" LIKE ('SUCCESS') AND "DIM_3"."col3" BETWEEN 20161213 AND 20161222 AND "DIM_4"."col4" > 0 ORDER BY DIM_1.col1