#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\sRechnungsbetrag\s\(inklusive Umsatzsteuer\))\s(?P<asd>\d{1,}).?(?P<fgh>\d{1,})?"
Local $sString = "Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR " & @CRLF & _
" Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR " & @CRLF & _
" Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR " & @CRLF & _
" Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")