import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\sRechnungsbetrag\\s\\(inklusive Umsatzsteuer\\))\\s(?P<asd>\\d{1,}).?(?P<fgh>\\d{1,})?";
final String string = "Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR \n"
+ " Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR \n"
+ " Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR \n"
+ " Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}