const regex = new RegExp('(?<=\\sRechnungsbetrag\\s\\(inklusive Umsatzsteuer\\))\\s(?P<asd>\\d{1,}).?(?P<fgh>\\d{1,})?', 'gm')
const str = `Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR
Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR
Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR
Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}