import re
regex = re.compile(r"(?<=\sRechnungsbetrag\s\(inklusive Umsatzsteuer\))\s(?P<asd>\d{1,}).?(?P<fgh>\d{1,})?", flags=re.MULTILINE)
test_str = ("Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR \n"
" Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR \n"
" Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR \n"
" Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")