import Foundation
let pattern = #"(?<=\sRechnungsbetrag\s\(inklusive Umsatzsteuer\))\s(?P<asd>\d{1,}).?(?P<fgh>\d{1,})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR
Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR
Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR
Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)