$re = '/(?=(http:\/\/.*turkcell|vodafone|avea\.)(?!com\.tr))/mi';
$str = 'sadfwesfs
http://vodafone.avea.turkcell.cm
http://tukcell.com.tr
http://www.turkcell.com.tr
sadsd http://avea.com.tr sads
dsadsa http://avea.com.tr sds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);