$re = '/([A-Z]+[A-Z ]*[A-Z])/';
$str = '
0
down vote
favorite
I got to extract string like "THE NEED OF FOLLOWING A RELIGION " from string. i extracted individual words like THE , NEED, OF... but i need complete string of capital letter like "THE NEED OF FOLLOWING A RELIGION" but not able to do so,, any help.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);