using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+(?:-\w+)?(?: +\/)? +\w+(?:-\w+)?).+";
string substitution = @"$1";
string input = @"AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11
BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING
TWO-HOLE PIPE STRAP 4"" 008004EG 72E 4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}