import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+(?:-\\w+)?(?: +\\/)? +\\w+(?:-\\w+)?).+";
final String string = "AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11\n"
+ "BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING\n"
+ "TWO-HOLE PIPE STRAP 4\" 008004EG 72E 4";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}