re = /^(\w+(?:-\w+)?(?: +\/)? +\w+(?:-\w+)?).+/m
str = 'AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11
BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING
TWO-HOLE PIPE STRAP 4" 008004EG 72E 4'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result