import Foundation
let pattern = #"^(\w+(?:-\w+)?(?: +\/)? +\w+(?:-\w+)?).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AO SMITH 100108283 4500W/240V SCREW-IN ELEMENT, 11
BRA14X18HEBU / P11-042 / 310-470NL BRASS 1/4 x 1/8 HEX BUSHING
TWO-HOLE PIPE STRAP 4" 008004EG 72E 4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)