const regex = /(?:([A-Za-z]+):\/\/)?(?:([A-Za-z0-9]+)\:([A-Za-z0-9]+)\@)?((?:[A-Za-z0-9]+\.)+[A-Za-z0-9]+)(?:\:([0-9]+))?(?:\/((?:[A-Za-z0-9]+)(?:\/[A-Za-z0-9]+)*(?:\.[A-Za-z0-9]+)?)?(\?[A-Za-z0-9]+=[A-Za-z0-9]+(?:&[A-Za-z0-9]+=[A-Za-z0-9]+)*)?(?:#([A-Za-z0-9]+))?)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([A-Za-z]+):\\\/\\\/)?(?:([A-Za-z0-9]+)\\:([A-Za-z0-9]+)\\@)?((?:[A-Za-z0-9]+\\.)+[A-Za-z0-9]+)(?:\\:([0-9]+))?(?:\\\/((?:[A-Za-z0-9]+)(?:\\\/[A-Za-z0-9]+)*(?:\\.[A-Za-z0-9]+)?)?(\\?[A-Za-z0-9]+=[A-Za-z0-9]+(?:&[A-Za-z0-9]+=[A-Za-z0-9]+)*)?(?:#([A-Za-z0-9]+))?)?', 'g')
const str = `http://root:123@google.com:80/search/wtf?qqqq=123&www=456#result
http://google.com/page/page.html
http://www.google.com/page?qqqq=123
omg.wtf.google.com/page/page.wtf?qqqq=123&eee=455&4444=445
lol.com/page#anchor
lol.com/page.php#ancohr
wtf.omg/?param=value
wtf.omg/#anchor
root:123@myhost.org/page.php#anchor
root:123@wtf.omg.lol.com/?param=233#anchor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}