# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\d]*?[.][\d]{2}(?=[\s\W])"
test_str = ("1.00\n"
"1.22\n\n"
"1\n"
"1.00000000\n"
"1.ab\n"
"1.(/\n"
"1.(\n"
"1.abs\n"
"3.123\n\n"
"2.13\n"
"12312312123.23\n"
"1,000.23\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.