import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\) # negative look-behind to make sure start is not escaped \n"
+ "(?: # start non-capture group for all possible match starts\n"
+ " # group 1, match dollar signs only \n"
+ " # single or double dollar sign enforced by look-arounds\n"
+ " ((?<!\\$)\\${1,2}(?!\\$))|\n"
+ " # group 2, match escaped parenthesis\n"
+ " (\\\\\\()|\n"
+ " # group 3, match escaped bracket\n"
+ " (\\\\\\[)| \n"
+ " # group 4, match begin equation\n"
+ " (\\\\begin\\{equation\\})\n"
+ ")\n"
+ "# if group 1 was start\n"
+ "(?(1)\n"
+ " # non greedy match everything in between\n"
+ " # group 1 matches do not support recursion\n"
+ " (.*?)(?<!\\\\)\n"
+ " # match ending double or single dollar signs\n"
+ " (?<!\\$)\\1(?!\\$)| \n"
+ "# else\n"
+ "(?:\n"
+ " # greedily and recursively match everything in between\n"
+ " # groups 2, 3 and 4 support recursion\n"
+ " (.*(?R)?.*)(?<!\\\\)\n"
+ " (?:\n"
+ " # if group 2 was start, escaped parenthesis is end\n"
+ " (?(2)\\\\\\)| \n"
+ " # if group 3 was start, escaped bracket is end\n"
+ " (?(3)\\\\\\]| \n"
+ " # else group 4 was start, match end equation\n"
+ " \\\\end\\{equation\\}\n"
+ " )\n"
+ "))))";
final String string = "sdfUma corda possui um movimento descrito pela seguinte função de onda: $$ y(x,t) = #x1# \\,\\hbox{sen}(\\frac{\\pi}{6}\\, x)\\,\\sin(#x2# t)\\,,\\;\\;\\hbox{com x e y em cm e t indo de 0 s a 10 s.} $$ A respeito deste movimento, alguém afirma: (i) $d$ A velocidade inicial de todos os pontos da corda é zero; (ii) A rapidez máxima de um ponto da corda é #f1# cm/s; (iii) O ponto da corda com $x=3$ cm não se move em nenhum instante.\\[sdf \\] \\begin{equation} sdfsdfsd \\end{equation}\n"
+ "Escolha essa função\n"
+ "$$Isso é um teste$$\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}