package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{16})-(.*?)-(\w+)-(\w+)\.`)
var str = `0989563275315984-1.0_xcvb-uploadtheDoc-hkl56895-20990415-05:11:24,897-2013027676-crtext-tiff.wrk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}