use strict;
my $str = 'CEO at TechCorp
General Manager of Construction Ltd
Chief Executive Officer at GreenTech
Directeur Général, Retail Co.
Directrice Générale, Fashion House
President of Logistics Firm
Founder of Innovative Solutions
Partner at Finance Group
COO at Healthcare Inc.
Owner of a Design Studio
CTO at Software Development Firm
President of HR Solutions
Junior Consultant at Business Partners
Freelance Marketing Advisor
Investor in Tech Startups
General Manager at Transport Services
CEO of Logistics & Supply
Founder of Non-Profit Organization
Chief Executive Officer at Construction Co.
Partner at Talent Acquisition Firm
';
my $regex = qr/\b(C(hief )?E(xecutive )?O(fficer)?|Direct(eur|rice)\sGénérale?|Founder|General\sManager|Owner|President|Partner|P(r[ée]sidente?)?D(irect(eur|rice))?G([ée]n[ée]rale?))\b(?!.*\b(Logistic|Industry|Industrial|Construction|Transport)\b)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}