import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"need\".*\\{.*,?\".*?\":(\".+?\").*\\}";
final String string = "\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}\n\n"
+ "\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C:\"ZABCD1235\"}\n\n"
+ "\"need\" : {\"A\":\"ZABCD123\" : {a\"B\":\"ZABCD123\"\n\n"
+ "\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}