# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"need\".*{.*,?\".*?\":(\".+?\").*}"
test_str = ("\"skip\" : {\"A\":\"ABCD123\",\"B\":\"ABCD1234\",\"C\":\"ABCD1235\"}\n\n"
"\"need\" : {\"A\":\"ZABCD123\",\"B\":\"ZABCD1234\",\"C:\"ZABCD1235\"}\n\n"
"\"need\" : {\"A\":\"ZABCD123\" : {a\"B\":\"ZABCD123\"\n\n"
"\"ignore\" : {\"A\":\"SABCD123\",\"B\":\"SABCD1234\",\"C\":\"SABCD1235\"}")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.