import Foundation
let pattern = #""need".*{.*,?".*?":(".+?").*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"skip" : {"A":"ABCD123","B":"ABCD1234","C":"ABCD1235"}
"need" : {"A":"ZABCD123","B":"ZABCD1234","C:"ZABCD1235"}
"need" : {"A":"ZABCD123" : {a"B":"ZABCD123"
"ignore" : {"A":"SABCD123","B":"SABCD1234","C":"SABCD1235"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}