#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/\*+ Useless CSS \*+\/)(.|[\r\n])*?END Useless CSS \*\*\*\*\/?"
Local $sString = "/**** Useless CSS ****/" & @CRLF & _
".my-class{" & @CRLF & _
" margin: 12px;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"/* Several Lines after including other comments **/" & @CRLF & _
"" & @CRLF & _
"/**** END Useless CSS ****/" & @CRLF & _
"" & @CRLF & _
".other {" & @CRLF & _
" padding: 12px;" & @CRLF & _
"}" & @CRLF & _
"/* Hello */"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)