$re = '/^[0-9,\-\s]+$/m';
$str = 'Чтобы я мог ввести 10, 11-20, 30.
10, 11-20, 30
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);