# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9\)\(\s+-]+(\s?(?:x|extension|ext\.)\s?[0-9-]+)?$"
test_str = ("555-555-5555\n"
	"555-555-5555 x55555\n"
	"555-555-5555x55555\n"
	"555-555-5555 extension 55555\n"
	"555-555-5555 ext. 55555\n"
	"(555) 555-5555\n"
	"5555555555\n"
	"555-5555\n"
	"5555555\n"
	"1-800-CONTACTS\n"
	"1-800-555-5555\n"
	"Hello world\n"
	"(555-555-5555\n"
	"0-999-0349300\n"
	"+43 984-899-46515\n"
	"+43 some bogus\n"
	"939403 03904 aosdf\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.