#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^ABC(?: 1(?: 0|$))+$"
Local $sString = "ABC 1" & @CRLF & _
"ABC 1 0" & @CRLF & _
"ABC 1 0 1" & @CRLF & _
"ABC 1 0 1 0" & @CRLF & _
"ABC 1 1 1 1" & @CRLF & _
"ABC 0 0 0 0" & @CRLF & _
"ABC 1 0 0 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")