using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ABC(?: 1(?: 0|$))+$";
string input = @"ABC 1
ABC 1 0
ABC 1 0 1
ABC 1 0 1 0
ABC 1 1 1 1
ABC 0 0 0 0
ABC 1 0 0 1";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}