import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ABC(?: 1(?: 0|$))+$";
final String string = "ABC 1\n"
+ "ABC 1 0\n"
+ "ABC 1 0 1\n"
+ "ABC 1 0 1 0\n"
+ "ABC 1 1 1 1\n"
+ "ABC 0 0 0 0\n"
+ "ABC 1 0 0 1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}