re = /\{(#[a-zA-Z0-9]{6})\}(.*?)(?=\{#[a-zA-Z0-9]{6}\}|$)/m
str = '{#FF00FF}test1{#112233}{placeholder} test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end