import Foundation
let pattern = #"(?m)^.*(?:\R.*){2}\K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1
2
3
4
5
6
7
8
9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #";"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)