// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[a-z]{2}.sporttu.com").unwrap();
let string = "ae.sporttu.com
al.sporttu.com
at.sporttu.com
au.sporttu.com
az.sporttu.com
ba.sporttu.com
badminton.sporttu.com
commonwealthgames.sporttu.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}