re = /\b(?:[0-9],[1-9][0-9]+|0,[1-9]|1,[2-9]|2,[3-9]|3,[4-9]|4,[5-9]|5,[6-9]|6,[7-9]|7,[8-9]|8,9)\b/
str = '7,10
5,3
0,1
8,9
0,20
10,20
21,12
1,12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end