$re = '/\.(\d+)\./';
$str = '/players/player.34360.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);