#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^aaa accounting system default (\n action-type |)start-stop(\n |) group tacacs\+"
Local $sString = "aaa accounting system default" & @CRLF & _
" action-type start-stop" & @CRLF & _
" group tacacs+" & @CRLF & _
"" & @CRLF & _
"aaa accounting system default start-stop group tacacs+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")