using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^aaa accounting system default (\n action-type |)start-stop(\n |) group tacacs\+";
string input = @"aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}