re = /^aaa accounting system default (\n action-type |)start-stop(\n |) group tacacs\+/m
str = 'aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end