import Foundation
let pattern = #"(<a.*href=)["'](.*)["']"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<h2><a href="http://www.google.com/test">Link</a></h2>2014-54-22 22:23"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"http://localhost/down.php?u=urldecode(\2)""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}