$re = '/(<a\b[^<>]*href=[\'"]?http[^<>]+)>/i';
$str = '<a href="https://www.codebales.com/regex-expressions-a-working-sheet" target="_blank">Regex examples sheet</a>';
$subst = "$1 target=\"_blank\" alt=\"Regex examples sheet\" title=\"Regex examples sheet\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;