import Foundation
let pattern = #"""
([\w-]+)
\h*
(=)
\h*
(
(["']).*(?!["'])
|
[\w-]+
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
th-is="atest"
key=value
what = about
one, two, three
foo = bar and bar=foo OR foobar = "foo,= key=foo,whatever = 'oops' bar"
foo="
test
"
foo ? time
IF foo = bar AND bar=foo OR foobar = "foo bar"
what = 'if this works'
this, is, a, test
what="if this works"
now=time
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)