Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<opening>\<\w)|(?<closing>\<?\/\w*\>)
/
g
Test String
New
<div Id='topDiv' Class='randomClass'><p Id='topP' Class='randomParagraph'></p>Blah<span></span>lkj<div Id='blahyay' ><div></div></div></div><div />