#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\d\w\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)"
Local $sString = "@a\sdfasdf sdsdfasdf " & @CRLF & _
"@as\dfasdf sdsdfasdf asdfasdf" & @CRLF & _
"@asdfa\sdf sdsdfasdf asdfasdf, asdasd" & @CRLF & _
"@as\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")