package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\d\w\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)`)
var str = `@a\sdfasdf sdsdfasdf
@as\dfasdf sdsdfasdf asdfasdf
@asdfa\sdf sdsdfasdf asdfasdf, asdasd
@as\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}