// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\d\w\\]+)\s*([\d\w]+)\s*(?:([\d\w]+)|,)").unwrap();
let string = "@a\\sdfasdf sdsdfasdf
@as\\dfasdf sdsdfasdf asdfasdf
@asdfa\\sdf sdsdfasdf asdfasdf, asdasd
@as\\dfasdf sdsdfasdf asdfasdf, asdasdasda,asdasdas
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}